blob: 1b505400916427e702c42f886747112975fb6586 [file] [log] [blame]
# Copyright 2018 The Chromium OS Authors. All rights reserved.
# Distributed under the terms of the GNU General Public License v2
EAPI=7
CROS_WORKON_COMMIT=("7f3fd85d0b2930213f2f863da507b1ea5d3087aa" "6bf4c9f0430bde6ad44eb096c49e432278b260f1" "22c5b21a61f6477ec943cde45a66526c0f2c11ad")
CROS_WORKON_TREE=("61f6e8290d3bdf5c09322bb48aaa49d59ce49d8c" "784f84ba540da966078c0440fa8289e360615521" "19a599e153588e7beddcc62b22f526879f2985cf")
CROS_WORKON_PROJECT=(
"chromiumos/platform/tast-tests"
"chromiumos/platform/tast"
"chromiumos/platform/fw-testing-configs"
)
CROS_WORKON_LOCALNAME=(
"platform/tast-tests"
"platform/tast"
"platform/tast-tests/src/chromiumos/tast/remote/firmware/data/fw-testing-configs"
)
CROS_WORKON_DESTDIR=(
"${S}"
"${S}/tast-base"
"${S}/src/chromiumos/tast/remote/firmware/data/fw-testing-configs"
)
CROS_GO_WORKSPACE=(
"${CROS_WORKON_DESTDIR[@]}"
)
CROS_GO_TEST=(
# Also test support packages that live above remote/bundles/.
"chromiumos/tast/..."
)
CROS_GO_VET=(
"${CROS_GO_TEST[@]}"
)
inherit cros-workon tast-bundle
DESCRIPTION="Bundle of remote integration tests for Chrome OS"
HOMEPAGE="https://chromium.googlesource.com/chromiumos/platform/tast-tests/"
LICENSE="BSD-Google"
KEYWORDS="*"
IUSE=""
# Build-time dependencies should be added to tast-build-deps, not here.
DEPEND="chromeos-base/tast-build-deps:="
RDEPEND="
dev-python/pillow
media-libs/opencv
"