blob: 438eb780294f8fa08c8c7961d13817804b08a030 [file] [log] [blame]
# Copyright 2018 The Chromium OS Authors. All rights reserved.
# Distributed under the terms of the GNU General Public License v2
EAPI=7
CROS_WORKON_COMMIT="6bf4c9f0430bde6ad44eb096c49e432278b260f1"
CROS_WORKON_TREE="784f84ba540da966078c0440fa8289e360615521"
CROS_WORKON_PROJECT="chromiumos/platform/tast"
CROS_WORKON_LOCALNAME="platform/tast"
CROS_GO_BINARIES=(
"chromiumos/tast/cmd/local_test_runner"
)
CROS_GO_TEST=(
"chromiumos/tast/cmd/local_test_runner/..."
)
CROS_GO_VET=(
"${CROS_GO_TEST[@]}"
)
inherit cros-go cros-workon
DESCRIPTION="Runner for local integration tests"
HOMEPAGE="https://chromium.googlesource.com/chromiumos/platform/tast/"
LICENSE="BSD-Google"
SLOT="0/0"
KEYWORDS="*"
IUSE=""
# Build-time dependencies should be added to tast-build-deps, not here.
DEPEND="chromeos-base/tast-build-deps:="
RDEPEND="
app-arch/tar
!chromeos-base/tast-common
"
src_prepare() {
# Disable cgo and PIE on building Tast binaries. See:
# https://crbug.com/976196
# https://github.com/golang/go/issues/30986#issuecomment-475626018
export CGO_ENABLED=0
export GOPIE=0
default
}