blob: a13bf04e78319ab01e3c0f687b0f881103f75d3a [file] [log] [blame]
# Copyright 2018 The Chromium OS Authors. All rights reserved.
# Distributed under the terms of the GNU General Public License v2
EAPI=7
CROS_WORKON_COMMIT="f5ab7c099e7a09ea07bf1587267462d6e342d1ec"
CROS_WORKON_TREE="1427c4c960670d99c8e2de8aa3ad2ad5f08da014"
PYTHON_COMPAT=( python3_{6..9} )
CROS_WORKON_PROJECT="chromiumos/third_party/autotest"
CROS_WORKON_LOCALNAME="third_party/autotest/files"
inherit cros-workon python-any-r1
DESCRIPTION="Compilation and runtime tests for toolchain"
HOMEPAGE="https://chromium.googlesource.com/chromiumos/third_party/autotest/"
LICENSE="BSD-Google"
KEYWORDS="*"
src_unpack() {
cros-workon_src_unpack
S+="/client/site_tests/platform_ToolchainTests/src"
}
src_test() {
einfo "Testing llvm-profdata..."
"${FILESDIR}/llvm-profdata-test.py" || die
default
}