blob: a15b7b66ab6e9811c11dd9b41dd3f85eb5ccce9c [file] [log] [blame]
# Copyright (c) 2010 The Chromium OS Authors. All rights reserved.
# Distributed under the terms of the GNU General Public License v2
EAPI=7
CROS_WORKON_COMMIT="c31013768eb4ed052c54df50c398f70f2d7ef36d"
CROS_WORKON_TREE="2ef2be6db7746b10beaf42e9a60b3706d653f9b6"
CROS_WORKON_PROJECT="chromiumos/platform/vboot_reference"
CROS_WORKON_LOCALNAME="platform/vboot_reference"
inherit cros-workon
DESCRIPTION="vboot tests"
HOMEPAGE="https://chromium.googlesource.com/chromiumos/platform/vboot_reference/"
LICENSE="BSD-Google"
KEYWORDS="*"
COMMON_DEPEND="dev-libs/libzip:=
dev-libs/openssl:=
sys-apps/flashrom:=
sys-apps/util-linux:="
RDEPEND="${COMMON_DEPEND}"
DEPEND="${COMMON_DEPEND}"
get_build_dir() {
echo "${S}/build-main"
}
src_compile() {
mkdir "$(get_build_dir)"
tc-export CC AR CXX PKG_CONFIG
# vboot_reference knows the flags to use
unset CFLAGS
emake BUILD="$(get_build_dir)" tests
}
src_install() {
emake BUILD="$(get_build_dir)" DESTDIR="${D}" install_dut_test
}