blob: 1719243830cd7c87d5bdf54b6cbbd0f4202737e7 [file] [log] [blame]
# Copyright 2016 The Chromium OS Authors. All rights reserved.
# Distributed under the terms of the GNU General Public License v2
EAPI=5
CROS_WORKON_COMMIT="eb2c7a1ed529de6e3ec91a32a5b45820f4ee2b81"
CROS_WORKON_TREE="892f23b1417ad8574ed3217510b5b05bef84ec02"
PYTHON_COMPAT=( python2_7 python{3_6,3_7,3_8} )
CROS_WORKON_PROJECT="chromiumos/third_party/autotest"
CROS_WORKON_LOCALNAME="third_party/autotest/files"
inherit autotest cros-workon flag-o-matic python-any-r1
DESCRIPTION="Public ARC autotests"
LICENSE="BSD-Google"
SLOT="0"
KEYWORDS="*"
RDEPEND="
dev-python/pyxattr
chromeos-base/chromeos-chrome
chromeos-base/autotest-chrome
chromeos-base/telemetry
"
DEPEND="${RDEPEND}"
IUSE="
+autotest
"
src_prepare() {
# Telemetry tests require the path to telemetry source to exist in order to
# build. Copy the telemetry source to a temporary directory that is writable,
# so that file removals in Telemetry source can be performed properly.
export TMP_DIR="$(mktemp -d)"
cp -r "${SYSROOT}/usr/local/telemetry" "${TMP_DIR}"
export PYTHONPATH="${TMP_DIR}/telemetry/src/third_party/catapult/telemetry"
autotest_src_prepare
}