| # Copyright 2015 The Chromium OS Authors. All rights reserved. |
| # Distributed under the terms of the GNU General Public License v2 |
| |
| EAPI=7 |
| |
| CROS_WORKON_INCREMENTAL_BUILD=1 |
| CROS_WORKON_LOCALNAME="platform2" |
| CROS_WORKON_PROJECT="chromiumos/platform2" |
| CROS_WORKON_OUTOFTREE_BUILD=1 |
| CROS_WORKON_SUBTREE="common-mk trim .gn" |
| |
| PLATFORM_SUBDIR="trim" |
| |
| inherit cros-workon platform |
| |
| DESCRIPTION="Stateful partition periodic trimmer" |
| HOMEPAGE="https://chromium.googlesource.com/chromiumos/platform2/+/master/trim/" |
| SRC_URI="" |
| |
| LICENSE="BSD-Google" |
| SLOT="0/0" |
| KEYWORDS="~*" |
| IUSE="" |
| |
| DEPEND="" |
| |
| RDEPEND="${DEPEND} |
| chromeos-base/chromeos-common-script |
| chromeos-base/chromeos-init |
| sys-apps/util-linux" |
| |
| platform_pkg_test() { |
| platform_test "run" "tests/chromeos-trim-test" |
| platform_test "run" "tests/chromeos-do_trim-test" |
| } |
| |
| src_install() { |
| insinto "/etc/init" |
| doins "init/trim.conf" |
| |
| insinto "/usr/share/cros" |
| doins "share/trim_utils.sh" |
| |
| dosbin "scripts/chromeos-trim" |
| } |