blob: 35eeced2a439e7a32e93134d273c2d7aa0761b07 [file] [log] [blame]
# Copyright 2021 The Chromium OS Authors. All rights reserved.
# Distributed under the terms of the GNU General Public License v2
EAPI=7
CROS_WORKON_COMMIT="d640cf36c1cb7d5b90023f4fb26b476a41d26b6f"
CROS_WORKON_TREE=("5ce03b99f33d64f242f02a09dcf165bdbad8d7d4" "efb8748309392ad76f174d36f109b9866bcf8241" "e7dba8c91c1f3257c34d4a7ffff0ea2537aeb6bb")
CROS_WORKON_INCREMENTAL_BUILD=1
CROS_WORKON_LOCALNAME="platform2"
CROS_WORKON_PROJECT="chromiumos/platform2"
CROS_WORKON_OUTOFTREE_BUILD=1
CROS_WORKON_SUBTREE="common-mk ml .gn"
PLATFORM_SUBDIR="ml/ml-client"
inherit cros-workon platform
DESCRIPTION="ML Service D-Bus client library for Chromium OS"
HOMEPAGE="https://chromium.googlesource.com/chromiumos/platform2/+/main/ml/"
LICENSE="BSD-Google"
KEYWORDS="*"
BDEPEND="
chromeos-base/chromeos-dbus-bindings:=
"
src_install() {
# Install D-Bus client library.
platform_install_dbus_client_lib "ml"
}