blob: 87311f7b327c978ad017c1ae0d57e48a15503ed4 [file] [log] [blame]
# Copyright 2022 The Chromium OS Authors. All rights reserved.
# Distributed under the terms of the GNU General Public License v2
EAPI=7
CROS_WORKON_COMMIT="d640cf36c1cb7d5b90023f4fb26b476a41d26b6f"
CROS_WORKON_TREE=("5ce03b99f33d64f242f02a09dcf165bdbad8d7d4" "3b33fc07daf512e548300eefbd028b622bc51b44" "e7dba8c91c1f3257c34d4a7ffff0ea2537aeb6bb")
CROS_WORKON_USE_VCSID="1"
CROS_WORKON_LOCALNAME="platform2"
CROS_WORKON_PROJECT="chromiumos/platform2"
CROS_WORKON_OUTOFTREE_BUILD=1
CROS_WORKON_SUBTREE="common-mk libcrossystem .gn"
PLATFORM_SUBDIR="libcrossystem"
inherit cros-workon platform
DESCRIPTION="Library to get Chromium OS system properties"
HOMEPAGE="https://chromium.googlesource.com/chromiumos/platform2/+/HEAD/libcrossystem"
LICENSE="BSD-Google"
KEYWORDS="*"
COMMON_DEPEND=""
RDEPEND="
${COMMON_DEPEND}
"
DEPEND="
${COMMON_DEPEND}
chromeos-base/vboot_reference:=
"
src_install() {
platform_install
}
platform_pkg_test() {
platform test_all
}