blob: d2516ae0b33356cc751b97e3faca8d26e0b978d4 [file] [log] [blame]
# Copyright 2016 The Chromium OS Authors. All rights reserved.
# Distributed under the terms of the GNU General Public License v2
EAPI=7
CROS_WORKON_COMMIT="d640cf36c1cb7d5b90023f4fb26b476a41d26b6f"
CROS_WORKON_TREE=("5ce03b99f33d64f242f02a09dcf165bdbad8d7d4" "bc5f4dc1eac5097a6d543202f4a5a5a4460f724b" "e7dba8c91c1f3257c34d4a7ffff0ea2537aeb6bb")
CROS_WORKON_INCREMENTAL_BUILD=1
CROS_WORKON_LOCALNAME="platform2"
CROS_WORKON_PROJECT="chromiumos/platform2"
CROS_WORKON_OUTOFTREE_BUILD=1
CROS_WORKON_SUBTREE="common-mk imageloader .gn"
PLATFORM_SUBDIR="imageloader"
inherit cros-workon platform user
DESCRIPTION="Allow mounting verified utility images"
HOMEPAGE="https://chromium.googlesource.com/chromiumos/platform2/+/HEAD/imageloader/"
LICENSE="BSD-Google"
KEYWORDS="*"
IUSE="fuzzer"
RDEPEND="
chromeos-base/vboot_reference:=
chromeos-base/minijail:=
dev-libs/openssl:=
dev-libs/protobuf:=
fuzzer? ( dev-libs/libprotobuf-mutator:= )
sys-fs/lvm2:="
DEPEND="${RDEPEND}
chromeos-base/system_api:=[fuzzer?]"
src_install() {
platform_install
local fuzzer_component_id="188251"
platform_fuzzer_install "${S}"/OWNERS "${OUT}"/imageloader_helper_process_receiver_fuzzer \
--comp "${fuzzer_component_id}"
platform_fuzzer_install "${S}"/OWNERS "${OUT}"/imageloader_manifest_fuzzer \
--dict "${S}"/fuzz/manifest.dict \
--comp "${fuzzer_component_id}"
}
platform_pkg_test() {
platform test_all
}
pkg_preinst() {
enewuser "imageloaderd"
enewgroup "imageloaderd"
}