blob: 1df880c301a57f6ed4e090049d72c74f9bea36c3 [file] [log] [blame]
# Copyright 2022 The Chromium OS Authors. All rights reserved.
# Distributed under the terms of the GNU General Public License v2
EAPI="7"
CROS_WORKON_COMMIT="d640cf36c1cb7d5b90023f4fb26b476a41d26b6f"
CROS_WORKON_TREE=("5ce03b99f33d64f242f02a09dcf165bdbad8d7d4" "9487cb70b8720982545a04ade6a4f464cdde53ac" "509fcdecd3a70e50e5aa4e48d65de2dbd6decdb9" "e7dba8c91c1f3257c34d4a7ffff0ea2537aeb6bb")
CROS_WORKON_INCREMENTAL_BUILD=1
CROS_WORKON_LOCALNAME="platform2"
CROS_WORKON_PROJECT="chromiumos/platform2"
CROS_WORKON_DESTDIR="${S}/platform2"
CROS_WORKON_SUBTREE="common-mk feature_usage metrics .gn"
PLATFORM_SUBDIR="feature_usage"
inherit cros-workon platform
DESCRIPTION="Provides a unified approach to report feature usage events"
LICENSE="BSD-Google"
SLOT="0/0"
KEYWORDS="*"
RDEPEND="
chromeos-base/metrics:=
"
DEPEND="
${RDEPEND}
"
src_install() {
# Install the static library
dolib.a "${OUT}"/libfeature_usage_static.a
# Install the header
insinto "/usr/include/feature_usage"
doins feature_usage_metrics.h
# Install the pc file
insinto "/usr/$(get_libdir)/pkgconfig"
doins "${OUT}/obj/feature_usage/libfeature_usage.pc"
}
platform_pkg_test() {
platform test_all
}