blob: 8712a481dea05726c927ffd795792ae8c83577cd [file] [log] [blame]
# Copyright 2022 The ChromiumOS Authors.
# Use of this source code is governed by a BSD-style license that can be
# found in the LICENSE file.
EAPI="7"
CROS_WORKON_COMMIT="d640cf36c1cb7d5b90023f4fb26b476a41d26b6f"
CROS_WORKON_TREE=("5ce03b99f33d64f242f02a09dcf165bdbad8d7d4" "83e2bdd8b74ac9fdb0c801679693d2bb0745064c" "e7dba8c91c1f3257c34d4a7ffff0ea2537aeb6bb")
CROS_WORKON_INCREMENTAL_BUILD=1
CROS_WORKON_LOCALNAME="platform2"
CROS_WORKON_PROJECT="chromiumos/platform2"
CROS_WORKON_DESTDIR="${S}/platform2"
CROS_WORKON_SUBTREE="common-mk chargesplash .gn"
PLATFORM_SUBDIR="chargesplash"
inherit cros-workon platform
DESCRIPTION="Frecon-based charging indicator"
HOMEPAGE="https://chromium.googlesource.com/chromiumos/platform2/+/HEAD/chargesplash"
LICENSE="BSD-Google"
SLOT="0/0"
KEYWORDS="*"
DEPEND="
chromeos-base/libec:=
"
RDEPEND="
${DEPEND}
sys-apps/frecon
"
src_install() {
dobin "${OUT}/chargesplash"
}
platform_pkg_test() {
platform test_all
}