blob: b60731b646595907358b6c238a0bed81ae3b8810 [file] [log] [blame]
# Copyright 2020 The Chromium OS Authors. All rights reserved.
# Use of this source code is governed by a BSD-style license that can be
# found in the LICENSE file.
EAPI=7
CROS_WORKON_COMMIT="d640cf36c1cb7d5b90023f4fb26b476a41d26b6f"
CROS_WORKON_TREE=("5ce03b99f33d64f242f02a09dcf165bdbad8d7d4" "88e843cfa45c09f42d875d1276aa8c51d84540c6" "e7dba8c91c1f3257c34d4a7ffff0ea2537aeb6bb")
CROS_WORKON_INCREMENTAL_BUILD="1"
CROS_WORKON_LOCALNAME="platform2"
CROS_WORKON_PROJECT="chromiumos/platform2"
CROS_WORKON_OUTOFTREE_BUILD=1
CROS_WORKON_SUBTREE="common-mk arc/vm/boot_notification_server .gn"
PLATFORM_SUBDIR="arc/vm/boot_notification_server"
inherit cros-workon platform user
DESCRIPTION="ARCVM boot notification server"
HOMEPAGE="https://chromium.googlesource.com/chromiumos/platform2/+/HEAD/arc/vm/boot_notification_server"
LICENSE="BSD-Google"
KEYWORDS="*"
SLOT="0/0"
IUSE="+seccomp"
src_install() {
newsbin "${OUT}/boot_notification_server" arcvm_boot_notification_server
insinto /etc/init
doins arcvm-boot-notification-server.conf
insinto /usr/share/policy
use seccomp && newins "arcvm_boot_notification_server-seccomp-${ARCH}.policy" arcvm_boot_notification_server-seccomp.policy
}
platform_pkg_test() {
platform_test "run" "${OUT}/boot_notification_server_testrunner"
}
pkg_preinst() {
enewuser arcvm-boot-notification-server
enewgroup arcvm-boot-notification-server
}