blob: 264922c85bb11a431158f9b6a4d8f4c1e6809594 [file] [log] [blame]
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
inherit udev
DESCRIPTION="Common files for multiple slots of sys-fs/fuse"
HOMEPAGE="https://github.com/libfuse/libfuse"
SRC_URI="https://github.com/libfuse/libfuse/releases/download/fuse-${PV}/fuse-${PV}.tar.xz"
LICENSE="GPL-2 LGPL-2.1"
SLOT="0"
KEYWORDS="*"
BDEPEND="virtual/pkgconfig"
RDEPEND="!<sys-fs/fuse-2.9.7-r1:0"
S=${WORKDIR}/fuse-${PV}
PATCHES=(
"${FILESDIR}"/${P}-conf.patch
)
src_install() {
udev_newrules util/udev.rules 99-fuse.rules
if use kernel_linux ; then
newinitd "${FILESDIR}"/fuse.init fuse
elif use kernel_FreeBSD ; then
newinitd "${FILESDIR}"/fuse-fbsd.init fuse
else
die "We don't know what init code install for your kernel, please file a bug."
fi
insinto /etc
doins util/fuse.conf
}