blob: 1650434822d0c27be0aa5a66a51a616cec5ff565 [file] [log] [blame]
# Copyright 2022 The Chromium OS Authors. All rights reserved.
# Distributed under the terms of the GNU General Public License v2
EAPI=7
CROS_WORKON_USE_VCSID="1"
CROS_WORKON_LOCALNAME="platform2"
CROS_WORKON_PROJECT="chromiumos/platform2"
CROS_WORKON_OUTOFTREE_BUILD=1
CROS_WORKON_INCREMENTAL_BUILD=1
# TODO(crbug.com/809389): Avoid directly including headers from other packages.
CROS_WORKON_SUBTREE="common-mk trunks u2fd .gn"
PLATFORM_SUBDIR="u2fd/client"
inherit cros-workon platform
DESCRIPTION="U2FHID library used by the internal corp U2F library"
HOMEPAGE="https://chromium.googlesource.com/chromiumos/platform2/+/HEAD/u2fd/client/"
LICENSE="BSD-Google"
KEYWORDS="~*"
IUSE="fuzzer cr50_onboard ti50_onboard"
COMMON_DEPEND="
fuzzer? (
chromeos-base/trunks:=
)
cr50_onboard? (
chromeos-base/trunks:=
)
ti50_onboard? (
chromeos-base/trunks:=
)
"
RDEPEND="${COMMON_DEPEND}"
DEPEND="${COMMON_DEPEND}
>=chromeos-base/protofiles-0.0.43:=
chromeos-base/system_api:=
"
src_install() {
platform_install
}