blob: 429d79b3044deab7640d1a8cfc265f11bf5e6a08 [file] [log] [blame]
# Copyright 2019 The Chromium OS Authors. All rights reserved.
# Distributed under the terms of the GNU General Public License v2
EAPI=7
CROS_WORKON_INCREMENTAL_BUILD="1"
CROS_WORKON_LOCALNAME="platform2"
CROS_WORKON_PROJECT="chromiumos/platform2"
CROS_WORKON_OUTOFTREE_BUILD=1
CROS_WORKON_SUBTREE="common-mk libmems .gn"
PLATFORM_SUBDIR="libmems"
inherit cros-workon platform
DESCRIPTION="MEMS support library for Chromium OS."
HOMEPAGE="https://chromium.googlesource.com/chromiumos/platform2/+/HEAD/libmems"
LICENSE="BSD-Google"
KEYWORDS="~*"
IUSE=""
COMMON_DEPEND="
net-libs/libiio:="
RDEPEND="${COMMON_DEPEND}"
DEPEND="${COMMON_DEPEND}
chromeos-base/system_api:="
src_install() {
platform_install
}
platform_pkg_test() {
platform test_all
}