blob: 59883b0fdb8b8368b2d53afe245d21a1043356b5 [file] [log] [blame]
# Copyright 2014 The Chromium OS Authors. All rights reserved.
# Distributed under the terms of the GNU General Public License v2
EAPI="5"
CROS_WORKON_COMMIT="b493dd5021f363e786ae38e91cf1aacac4be09cd"
CROS_WORKON_TREE="f8f2bb698a2b96ec55bcd7e564b813aea6e1c7b5"
CROS_WORKON_INCREMENTAL_BUILD=1
CROS_WORKON_LOCALNAME="platform2"
CROS_WORKON_PROJECT="chromiumos/platform2"
CROS_WORKON_OUTOFTREE_BUILD=1
CROS_WORKON_SUBTREE="chromeos-dbus-bindings"
inherit cros-go cros-workon
DESCRIPTION="Utility for building Chrome D-Bus bindings from an XML description"
HOMEPAGE="https://chromium.googlesource.com/chromiumos/platform2/+/HEAD/chromeos-dbus-bindings"
LICENSE="BSD-Google"
SLOT="0"
KEYWORDS="*"
IUSE=""
CROS_GO_BINARIES=(
"go.chromium.org/chromiumos/dbusbindings/cmd/generator:/usr/bin/go-generate-chromeos-dbus-bindings"
)
CROS_GO_TEST=(
"go.chromium.org/chromiumos/dbusbindings/..."
)
CROS_GO_VET=(
"${CROS_GO_TEST[@]}"
)
RDEPEND="dev-go/cmp"
DEPEND="${RDEPEND}"
src_unpack() {
cros-workon_src_unpack
CROS_GO_WORKSPACE="${S}/chromeos-dbus-bindings/go"
}