blob: c1e7335bd10f6cafccc03b0c22c58ed6957ea1ad [file] [log] [blame]
# Copyright 2014 The Chromium OS Authors. All rights reserved.
# Distributed under the terms of the GNU General Public License v2
EAPI=7
CROS_WORKON_COMMIT="c142078820d0707858873cedb290a78d36f531af"
CROS_WORKON_TREE=("eec5ce9cfadd268344b02efdbec7465fbc391a9e" "ae1501a02c3893627432d1114e83009270cc821d" "e7dba8c91c1f3257c34d4a7ffff0ea2537aeb6bb")
CROS_WORKON_INCREMENTAL_BUILD=1
CROS_WORKON_USE_VCSID=1
CROS_WORKON_LOCALNAME="platform2"
CROS_WORKON_PROJECT="chromiumos/platform2"
CROS_WORKON_OUTOFTREE_BUILD=1
CROS_WORKON_SUBTREE="common-mk easy-unlock .gn"
PLATFORM_SUBDIR="easy-unlock"
inherit cros-workon platform user
DESCRIPTION="Service for supporting Easy Unlock in Chromium OS"
HOMEPAGE="https://chromium.googlesource.com/chromiumos/platform2/+/master/easy-unlock/"
LICENSE="BSD-Google"
SLOT="0/0"
KEYWORDS="*"
IUSE=""
COMMON_DEPEND="
chromeos-base/easy-unlock-crypto:=
"
RDEPEND="${COMMON_DEPEND}"
DEPEND="
${COMMON_DEPEND}
chromeos-base/system_api:=
"
pkg_preinst() {
enewuser easy-unlock
enewgroup easy-unlock
}
src_install() {
exeinto /opt/google/easy_unlock
doexe "${OUT}/easy_unlock"
insinto /etc/dbus-1/system.d
doins org.chromium.EasyUnlock.conf
insinto /usr/share/dbus-1/system-services
doins org.chromium.EasyUnlock.service
insinto /etc/init
doins init/easy-unlock.conf
insinto /usr/share/dbus-1/interfaces
doins dbus_bindings/org.chromium.EasyUnlockInterface.xml
}
platform_pkg_test() {
platform_test "run" "${OUT}/easy_unlock_test_runner"
}