blob: 8a9eb97587201a48766ae77253ef648b7eca1c8b [file] [log] [blame]
# Copyright (c) 2010 The Chromium OS Authors. All rights reserved.
# Distributed under the terms of the GNU General Public License v2
EAPI=7
CROS_WORKON_COMMIT="600c679cd66265a54ee63b1747abfff6f94a25ad"
CROS_WORKON_TREE="6777caa775b33052fb356add81c9c057de37b7ce"
CROS_WORKON_PROJECT="chromiumos/platform/vboot_reference"
inherit cros-workon autotest
DESCRIPTION="vboot tests"
HOMEPAGE="https://chromium.googlesource.com/chromiumos/platform/vboot_reference/"
SRC_URI=""
LICENSE="BSD-Google"
KEYWORDS="*"
# Enable autotest by default.
IUSE="${IUSE} +autotest"
IUSE_TESTS="
+tests_firmware_VbootCrypto
"
IUSE="${IUSE} ${IUSE_TESTS}"
CROS_WORKON_LOCALNAME=platform/vboot_reference
# path from root of repo
AUTOTEST_CLIENT_SITE_TESTS=autotest/client
src_compile() {
# for Makefile
export VBOOT_SRC_DIR=${WORKDIR}/${P}
autotest_src_compile
}