blob: 8cf0d8c92a25313c6284987b7636f41db3d332d6 [file] [log] [blame]
# Copyright 2017 The Chromium OS Authors. All rights reserved.
# Distributed under the terms of the GNU General Public License v2
EAPI=5
CROS_WORKON_COMMIT="12a8d083f711ceb3a6ab9f0808f90568320d89a8"
CROS_WORKON_TREE=("e7dba8c91c1f3257c34d4a7ffff0ea2537aeb6bb" "4be8d3ae5664634825afc2e6e4b8c24816ee9b9e" "2caba31198fff61bbb98413326cbc176c0a9a685" "66167969f21d9a7bd20fc7fd2e582ad849d7d8eb" "fcb83ee936c01758d591bb6f7a7734f054dd30ae" "aae8bf048bbe1147ff2aa47f59de29bad1b6355d" "81608e81e7a1a6aacd7096a66fd44588c1d5ece9")
CROS_WORKON_PROJECT="chromiumos/platform2"
CROS_WORKON_LOCALNAME="../platform2"
# TODO(crbug.com/809389): Avoid directly including headers from other packages.
CROS_WORKON_SUBTREE=".gn camera/build camera/common camera/hal/usb camera/include camera/mojo common-mk"
CROS_WORKON_OUTOFTREE_BUILD="1"
CROS_WORKON_INCREMENTAL_BUILD="1"
PLATFORM_SUBDIR="camera/hal/usb"
inherit cros-camera cros-workon platform
DESCRIPTION="Chrome OS USB camera HAL v3."
LICENSE="BSD-Google"
SLOT="0"
KEYWORDS="*"
IUSE="asan"
RDEPEND="
chromeos-base/cros-camera-android-deps
chromeos-base/cros-camera-libs
dev-libs/re2
media-libs/libsync"
DEPEND="${RDEPEND}
media-libs/libyuv
virtual/pkgconfig"
src_install() {
platform_src_install
cros-camera_dohal "${OUT}/lib/libcamera_hal.so" usb.so
}
platform_pkg_test() {
local tests=(
image_processor_test
)
local test_bin
for test_bin in "${tests[@]}"; do
# TODO(b/193747946): Remove the condition once we solve the camera
# libraries missing when running with asan enabled issue.
if ! use asan; then
platform_test run "${OUT}/${test_bin}"
fi
done
}