blob: c16e7ab8cdb3f5a0a199347c09fd3778b5175461 [file] [log] [blame]
# Copyright 2019 The Chromium OS Authors. All rights reserved.
# Distributed under the terms of the GNU General Public License v2
EAPI=7
CROS_WORKON_COMMIT="08c058a591621090c489775caafba4713ba70153"
CROS_WORKON_TREE=("eec5ce9cfadd268344b02efdbec7465fbc391a9e" "db49e6090983c78aaaea558e0aede1a93db976be" "35209d034fbd2e33442b08fbe02ec0d600922a35" "e7dba8c91c1f3257c34d4a7ffff0ea2537aeb6bb")
CROS_WORKON_INCREMENTAL_BUILD="1"
CROS_WORKON_LOCALNAME="platform2"
CROS_WORKON_PROJECT="chromiumos/platform2"
CROS_WORKON_OUTOFTREE_BUILD=1
# TODO(crbug.com/809389): Remove libmems from this list.
CROS_WORKON_SUBTREE="common-mk mems_setup libmems .gn"
PLATFORM_SUBDIR="mems_setup"
inherit cros-workon platform
DESCRIPTION="MEMS Setup for Chromium OS."
HOMEPAGE="https://chromium.googlesource.com/chromiumos/platform2/+/master/mems_setup"
LICENSE="BSD-Google"
KEYWORDS="*"
IUSE=""
COMMON_DEPEND="
chromeos-base/libmems:=
net-libs/libiio:="
RDEPEND="${COMMON_DEPEND}"
DEPEND="${COMMON_DEPEND}
chromeos-base/system_api:="
src_install() {
dosbin "${OUT}"/mems_setup
}
platform_pkg_test() {
local tests=(
mems_setup_testrunner
)
local test_bin
for test_bin in "${tests[@]}"; do
platform_test "run" "${OUT}/${test_bin}"
done
}