blob: 8fbaf099c3130bbf8ebb0bed50fe262f7d8b5375 [file] [log] [blame]
# Copyright 2018 The Chromium OS Authors. All rights reserved.
# Distributed under the terms of the GNU General Public License v2
EAPI=7
CROS_WORKON_COMMIT=("dda51a9c1495b3de6cdccc4226377192c5910263" "4527403fcdf7416eae625fa39718b6c8f9842987" "bb8eec2db8f44e894f23349686b6eef38bbad837")
CROS_WORKON_TREE=("eaa395f77aa10c56c4ee654d829622f678932153" "7c60117e575ed6b6cc1bf3e5c39ca9b1577253a4" "0d83a3e9add33f945dded638bf41797b945b1dd1")
CROS_WORKON_PROJECT=(
"chromiumos/platform/tast-tests"
"chromiumos/platform/tast"
"chromiumos/platform/fw-testing-configs"
)
CROS_WORKON_LOCALNAME=(
"platform/tast-tests"
"platform/tast"
"platform/tast-tests/src/chromiumos/tast/remote/firmware/data/fw-testing-configs"
)
CROS_WORKON_DESTDIR=(
"${S}"
"${S}/tast-base"
"${S}/src/chromiumos/tast/remote/firmware/data/fw-testing-configs"
)
CROS_GO_WORKSPACE=(
"${CROS_WORKON_DESTDIR[@]}"
)
CROS_GO_TEST=(
# Also test support packages that live above remote/bundles/.
"chromiumos/tast/..."
)
CROS_GO_VET=(
"${CROS_GO_TEST[@]}"
)
inherit cros-workon tast-bundle
DESCRIPTION="Bundle of remote integration tests for Chrome OS"
HOMEPAGE="https://chromium.googlesource.com/chromiumos/platform/tast-tests/"
LICENSE="BSD-Google"
KEYWORDS="*"
IUSE=""
# Build-time dependencies should be added to tast-build-deps, not here.
DEPEND="chromeos-base/tast-build-deps:="
RDEPEND="
dev-python/pillow
media-libs/opencv
"