blob: 63ed2738f001e4738354df1cf1e271d5416ef92a [file] [log] [blame]
# Copyright 2020 The Chromium OS Authors. All rights reserved.
# Distributed under the terms of the GNU General Public License v2
EAPI=7
CROS_WORKON_COMMIT="0a70acf40b774cf9c5d4f41cb5787d3862ca9348"
CROS_WORKON_TREE=("aa81756947ecfdd38b22f42eed8eeafa40431079" "7c400445b4ae74c9a1f673f1aaebed6f9df24894" "e7dba8c91c1f3257c34d4a7ffff0ea2537aeb6bb")
CROS_WORKON_PROJECT="chromiumos/platform2"
CROS_WORKON_LOCALNAME="platform2"
CROS_WORKON_OUTOFTREE_BUILD=1
CROS_WORKON_INCREMENTAL_BUILD=1
CROS_WORKON_SUBTREE="common-mk shill .gn"
PLATFORM_SUBDIR="shill/net"
inherit cros-workon platform
DESCRIPTION="Shill networking component interface library"
HOMEPAGE="https://chromium.googlesource.com/chromiumos/platform2/+/HEAD/shill/net"
LICENSE="BSD-Google"
SLOT="0"
KEYWORDS="*"
IUSE="fuzzer +wifi"
DEPEND=""
RDEPEND="
!<chromeos-base/shill-0.0.5
"
src_install() {
# Install libshill-net library.
insinto "/usr/$(get_libdir)/pkgconfig"
local v="$(libchrome_ver)"
./preinstall.sh "${OUT}" "${v}"
dolib.so "${OUT}/lib/libshill-net.so"
doins "${OUT}/lib/libshill-net.pc"
# TODO(crbug/920513): Remove both.
# Backward compatibility before all usages of versioned libraries are
# removed.
doins "${OUT}/lib/libshill-net-${v}.pc"
# Backward compatibility before developers has built their software against
# new shill.
dosym libshill-net.so "/usr/$(get_libdir)/libshill-net-${v}.so"
# Install header files from libshill-net.
insinto /usr/include/shill/net
doins ./*.h
local fuzzer
for fuzzer in "${OUT}"/*_fuzzer; do
platform_fuzzer_install "${S}"/../OWNERS "${fuzzer}"
done
}
platform_pkg_test() {
platform_test "run" "${OUT}/shill_net_test"
}