| # Copyright 2018 The Chromium OS Authors. All rights reserved. |
| # Distributed under the terms of the GNU General Public License v2 |
| |
| EAPI=7 |
| CROS_WORKON_COMMIT=("c21df20297534ad71c6cea3ac0b364abfcfecfbc" "e4d08848f7ee842b8cc7eef4b5ac40371eab0c5a" "22c5b21a61f6477ec943cde45a66526c0f2c11ad") |
| CROS_WORKON_TREE=("b446e1f3297f19f2d5d7dde235706a9d22be6bb0" "f962a7d69f70f98e292bc4a8161b165a1d3af867" "19a599e153588e7beddcc62b22f526879f2985cf") |
| CROS_WORKON_PROJECT=( |
| "chromiumos/platform/tast-tests" |
| "chromiumos/platform/tast" |
| "chromiumos/platform/fw-testing-configs" |
| ) |
| CROS_WORKON_LOCALNAME=( |
| "platform/tast-tests" |
| "platform/tast" |
| "platform/tast-tests/src/chromiumos/tast/remote/firmware/data/fw-testing-configs" |
| ) |
| CROS_WORKON_DESTDIR=( |
| "${S}" |
| "${S}/tast-base" |
| "${S}/src/chromiumos/tast/remote/firmware/data/fw-testing-configs" |
| ) |
| |
| CROS_GO_WORKSPACE=( |
| "${CROS_WORKON_DESTDIR[@]}" |
| ) |
| |
| CROS_GO_TEST=( |
| # Also test support packages that live above remote/bundles/. |
| "chromiumos/tast/..." |
| ) |
| CROS_GO_VET=( |
| "${CROS_GO_TEST[@]}" |
| ) |
| |
| inherit cros-workon tast-bundle |
| |
| DESCRIPTION="Bundle of remote integration tests for Chrome OS" |
| HOMEPAGE="https://chromium.googlesource.com/chromiumos/platform/tast-tests/" |
| |
| LICENSE="BSD-Google" |
| KEYWORDS="*" |
| IUSE="" |
| |
| # Build-time dependencies should be added to tast-build-deps, not here. |
| DEPEND="chromeos-base/tast-build-deps:=" |
| |
| RDEPEND=" |
| dev-python/pillow |
| media-libs/opencv |
| " |