| # Copyright 2018 The Chromium OS Authors. All rights reserved. |
| # Distributed under the terms of the GNU General Public License v2 |
| |
| EAPI=7 |
| CROS_WORKON_COMMIT=("c21df20297534ad71c6cea3ac0b364abfcfecfbc" "e4d08848f7ee842b8cc7eef4b5ac40371eab0c5a") |
| CROS_WORKON_TREE=("b446e1f3297f19f2d5d7dde235706a9d22be6bb0" "f962a7d69f70f98e292bc4a8161b165a1d3af867") |
| CROS_WORKON_PROJECT=( |
| "chromiumos/platform/tast-tests" |
| "chromiumos/platform/tast" |
| ) |
| CROS_WORKON_LOCALNAME=( |
| "platform/tast-tests" |
| "platform/tast" |
| ) |
| CROS_WORKON_DESTDIR=( |
| "${S}" |
| "${S}/tast-base" |
| ) |
| |
| CROS_GO_WORKSPACE=( |
| "${CROS_WORKON_DESTDIR[@]}" |
| ) |
| |
| CROS_GO_TEST=( |
| # Also test support packages that live above local/bundles/. |
| "chromiumos/tast/..." |
| ) |
| CROS_GO_VET=( |
| "${CROS_GO_TEST[@]}" |
| ) |
| |
| inherit cros-workon tast-bundle |
| |
| DESCRIPTION="Bundle of local integration tests for Chrome OS" |
| HOMEPAGE="https://chromium.googlesource.com/chromiumos/platform/tast-tests/" |
| |
| LICENSE="Apache-2.0 BSD-Google" |
| SLOT="0/0" |
| KEYWORDS="*" |
| IUSE="arc chromeless_tty chromeless_tests cups" |
| |
| # Build-time dependencies should be added to tast-build-deps, not here. |
| DEPEND="chromeos-base/tast-build-deps:=" |
| |
| RDEPEND=" |
| chromeos-base/policy-testserver |
| chromeos-base/tast-local-helpers-cros |
| chromeos-base/virtual-usb-printer |
| chromeos-base/wprgo |
| !chromeless_tty? ( |
| !chromeless_tests? ( |
| chromeos-base/drm-tests |
| ) |
| ) |
| dev-libs/openssl:0= |
| arc? ( |
| chromeos-base/tast-local-apks-cros |
| dev-util/android-tools |
| dev-util/android-uiautomator-server |
| ) |
| net-misc/curl |
| cups? ( |
| net-print/ippsample |
| ) |
| sys-apps/memtester |
| sys-apps/rootdev |
| virtual/udev |
| " |