blob: 1d79857ea4b513c15b441717b82a812c8aaefe87 [file] [log] [blame]
# Copyright 2022 The ChromiumOS Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
CROS_WORKON_COMMIT="ba431ef8e278505075006e2e2361bcf2bb864b42"
CROS_WORKON_TREE=("836ea6c34519b26b67b67b352a4e2e3983987589" "1c36d69299744dc6f2c28c6185053d8e6def3f6f" "f91b6afd5f2ae04ee9a2c19109a3a4a36f7659e6")
CROS_WORKON_INCREMENTAL_BUILD=1
CROS_WORKON_LOCALNAME="platform2"
CROS_WORKON_PROJECT="chromiumos/platform2"
CROS_WORKON_OUTOFTREE_BUILD=1
CROS_WORKON_SUBTREE="common-mk hiberman .gn"
PLATFORM_NATIVE_TEST="yes"
PLATFORM_SUBDIR="hiberman/client"
inherit cros-workon platform
DESCRIPTION="Hibernate manager DBus client library for Chromium OS"
HOMEPAGE="https://chromium.googlesource.com/chromiumos/platform2/+/HEAD/hiberman/"
LICENSE="BSD-Google"
KEYWORDS="*"
BDEPEND="
chromeos-base/chromeos-dbus-bindings
"
# Workaround to rebuild this package on the chromeos-dbus-bindings update.
# Please find the comment in chromeos-dbus-bindings for its background.
DEPEND="
chromeos-base/chromeos-dbus-bindings:=
"
src_install() {
platform_src_install
# Install DBus client library.
platform_install_dbus_client_lib "hibernate"
}