blob: 59af9b66a58a9a7cba310b00e012492bd23c22e0 [file] [log] [blame]
# Copyright 2018 The Chromium OS Authors. All rights reserved.
# Distributed under the terms of the GNU General Public License v2
EAPI=7
CROS_WORKON_COMMIT="22901c01730f28b4de16bc7f153a85bb211ab992"
CROS_WORKON_TREE="d3a7b4f8a6a7076958cbf833fb4b8a56ea1bac83"
PYTHON_COMPAT=( python3_{6..9} )
CROS_WORKON_PROJECT="chromiumos/third_party/autotest"
CROS_WORKON_LOCALNAME="third_party/autotest/files"
inherit cros-workon python-any-r1
DESCRIPTION="Compilation and runtime tests for toolchain"
HOMEPAGE="https://chromium.googlesource.com/chromiumos/third_party/autotest/"
LICENSE="BSD-Google"
KEYWORDS="*"
src_unpack() {
cros-workon_src_unpack
S+="/client/site_tests/platform_ToolchainTests/src"
}
src_test() {
einfo "Testing llvm-profdata..."
"${FILESDIR}/llvm-profdata-test.py" || die
default
}