blob: 08009a8887282935d9126b652f7dac75b88e769a [file] [log] [blame]
# Copyright 2018 The Chromium OS Authors. All rights reserved.
# Distributed under the terms of the GNU General Public License v2
EAPI=7
CROS_WORKON_COMMIT=("afc13a3742d92490f6ce436cd9e7d736a517c322" "af699a2a75b8905cb30cd7c6a0be61cdb1593d3e" "fdcd88182cfd3d40596011819c24bb4927e82d1e")
CROS_WORKON_TREE=("1a4e73077801be53cd0ba2d26318002a3b58a3bf" "85ff64bf9199aa5473db461312b3208004cbb7e0" "3b88e01b4c689a52c6a8eed97043023877ad2278")
CROS_WORKON_PROJECT=(
"chromiumos/platform/tast-tests"
"chromiumos/platform/tast"
"chromiumos/platform/fw-testing-configs"
)
CROS_WORKON_LOCALNAME=(
"platform/tast-tests"
"platform/tast"
"platform/tast-tests/src/chromiumos/tast/remote/firmware/data/fw-testing-configs"
)
CROS_WORKON_DESTDIR=(
"${S}"
"${S}/tast-base"
"${S}/src/chromiumos/tast/remote/firmware/data/fw-testing-configs"
)
CROS_GO_WORKSPACE=(
"${CROS_WORKON_DESTDIR[@]}"
)
CROS_GO_TEST=(
# Also test support packages that live above remote/bundles/.
"chromiumos/tast/..."
)
CROS_GO_VET=(
"${CROS_GO_TEST[@]}"
)
TAST_BUNDLE_EXCLUDE_DATA_FILES="1"
inherit cros-workon tast-bundle
DESCRIPTION="Bundle of remote integration tests for Chrome OS"
HOMEPAGE="https://chromium.googlesource.com/chromiumos/platform/tast-tests/"
LICENSE="BSD-Google"
KEYWORDS="*"
IUSE=""
# Build-time dependencies should be added to tast-build-deps, not here.
DEPEND="chromeos-base/tast-build-deps:="
RDEPEND="
chromeos-base/tast-tests-remote-data
dev-python/pillow
media-libs/opencv
"