blob: 336d01548a4e3a11debcbaa2f0e7aaf2defa08c5 [file] [log] [blame]
# Copyright 2021 The Chromium OS Authors. All rights reserved.
# Use of this source code is governed by a BSD-style license that can be
# found in the LICENSE file.
EAPI=7
CROS_WORKON_COMMIT=("444f620e1a883cd67e2ead9678a65e077beb8983" "7a01213d5fdc415d99fe5060a0f06fccdcee018a")
CROS_WORKON_TREE="9ad282fc313b93ae44031fb8c6a4ec2163e8b225"
CROS_WORKON_PROJECT=(
"chromiumos/platform/tast-tests"
"chromiumos/platform/fw-testing-configs"
)
CROS_WORKON_LOCALNAME=(
"platform/tast-tests"
"platform/tast-tests/src/chromiumos/tast/remote/firmware/data/fw-testing-configs"
)
CROS_WORKON_DESTDIR=(
"${S}"
"${S}/src/chromiumos/tast/remote/firmware/data/fw-testing-configs"
)
# There are symlinks between remote data to local data, so we can't make the
# subtree "src/chromiumos/tast/remote".
# TODO(oka): have a clear separation between local and remote, and make that
# happen.
CROS_WORKON_SUBTREE=("src/chromiumos/tast")
inherit cros-workon tast-bundle-data
DESCRIPTION="Data files for remote Tast tests"
HOMEPAGE="https://chromium.googlesource.com/chromiumos/platform/tast-tests"
LICENSE="BSD-Google GPL-3"
SLOT="0/0"
KEYWORDS="*"
DEPEND="sys-firmware/ap-firmware-config:="
RDEPEND="!<chromeos-base/tast-remote-tests-cros-0.0.2"
src_install() {
tast-bundle-data_src_install
insinto /usr/share/tast/data/chromiumos/tast/remote/bundles/cros/firmware/data
doins /usr/share/ap_firmware_config/fw-config.json
}