blob: d7f0a79ae493ea4ce8378d47af6ee9390671ea4c [file] [log] [blame]
# Copyright 2018 The Chromium OS Authors. All rights reserved.
# Distributed under the terms of the GNU General Public License v2
EAPI=7
CROS_WORKON_COMMIT=("444f620e1a883cd67e2ead9678a65e077beb8983" "9e62f787bdb066d6f6d187ba4c5614e81a2289c7")
CROS_WORKON_TREE=("ff09aab6d1dadecd0b51ecb6bb26222906ca51eb" "22dce69eb9b87f1074930ff8ca5592eb2312c7da")
CROS_WORKON_PROJECT=(
"chromiumos/platform/tast-tests"
"chromiumos/platform/tast"
)
CROS_WORKON_LOCALNAME=(
"platform/tast-tests"
"platform/tast"
)
CROS_WORKON_DESTDIR=(
"${S}"
"${S}/tast-base"
)
CROS_GO_WORKSPACE=(
"${CROS_WORKON_DESTDIR[@]}"
)
CROS_GO_TEST=(
# Also test support packages that live above local/bundles/.
"chromiumos/tast/..."
)
CROS_GO_VET=(
"${CROS_GO_TEST[@]}"
)
TAST_BUNDLE_EXCLUDE_DATA_FILES="1"
inherit cros-workon tast-bundle
DESCRIPTION="Bundle of local integration tests for Chrome OS"
HOMEPAGE="https://chromium.googlesource.com/chromiumos/platform/tast-tests/"
LICENSE="Apache-2.0 BSD-Google"
SLOT="0/0"
KEYWORDS="*"
IUSE="arc chromeless_tty chromeless_tests cups"
# Build-time dependencies should be added to tast-build-deps, not here.
DEPEND="chromeos-base/tast-build-deps:="
RDEPEND="
chromeos-base/policy-testserver
chromeos-base/tast-local-helpers-cros
chromeos-base/tast-tests-local-data
chromeos-base/virtual-usb-printer
chromeos-base/wprgo
!chromeless_tty? (
!chromeless_tests? (
chromeos-base/drm-tests
)
)
dev-libs/openssl:0=
arc? (
chromeos-base/tast-local-apks-cros
dev-util/android-tools
dev-util/android-uiautomator-server
)
net-misc/curl
cups? (
net-print/ippsample
)
sys-apps/memtester
sys-apps/rootdev
virtual/udev
"