blob: 45ba5d1b0df9d2088195e14247c683fad1dbe1d9 [file] [log] [blame]
# Copyright 2016 The Chromium OS Authors. All rights reserved.
# Distributed under the terms of the GNU General Public License v2
EAPI=7
CROS_WORKON_COMMIT="b7dc4c6503f6867018a5bae06421d1e7c822f926"
CROS_WORKON_TREE="3e37a14b7a231b10cb77373f8804f8fc0978089e"
CROS_WORKON_PROJECT="chromiumos/platform/ec"
CROS_WORKON_LOCALNAME="platform/ec"
CROS_WORKON_INCREMENTAL_BUILD=1
PYTHON_COMPAT=( python3_{6,7,8} pypy3 )
inherit cros-workon python-r1
DESCRIPTION="Chrome OS EC Utility Helper"
HOMEPAGE="https://chromium.googlesource.com/chromiumos/platform/ec/"
SRC_URI=""
LICENSE="BSD-Google"
SLOT="0/0"
KEYWORDS="*"
IUSE="biod -cr50_onboard"
# flash_fp_mcu depends on stm32mon (ec-devutils)
RDEPEND="
${PYTHON_DEPS}
chromeos-base/ec-utils
biod? (
chromeos-base/ec-devutils
dev-util/shflags
)
"
src_compile() {
tc-export CC
if use cr50_onboard; then
emake -C extra/rma_reset
fi
}
src_install() {
dobin "util/battery_temp"
dosbin "util/inject-keys.py"
if use cr50_onboard; then
dobin "extra/rma_reset/rma_reset"
fi
if use biod; then
einfo "Installing flash_fp_mcu and fptool"
dobin "util/flash_fp_mcu"
newbin "util/fptool.py" "fptool"
fi
}