blob: cd23dbe1e1f57735b2d4efa5d080a6bfb8619cb2 [file] [log] [blame]
# Copyright 2018 The Chromium OS Authors. All rights reserved.
# Distributed under the terms of the GNU General Public License v2
EAPI=7
CROS_WORKON_COMMIT=("a6374cc2f2955e963ab4597ca6a28c4d04abe158" "13616d08cad0bc1cdd0fad7d7d8d4a0b7e982429" "c5889adab57bc6394a900a60d6f943f7918fef8d")
CROS_WORKON_TREE=("11243d18597fb4ac1685d0b9677a40e4c5607007" "7013f34ad42ab905a23eae5dca6590d937c60d33" "dd84017ea39c62ab8790679abd24e7d37367ac48")
CROS_WORKON_PROJECT=(
"chromiumos/platform/tast-tests"
"chromiumos/platform/tast"
"chromiumos/platform/fw-testing-configs"
)
CROS_WORKON_LOCALNAME=(
"platform/tast-tests"
"platform/tast"
"platform/tast-tests/src/chromiumos/tast/remote/firmware/data/fw-testing-configs"
)
CROS_WORKON_DESTDIR=(
"${S}"
"${S}/tast-base"
"${S}/src/chromiumos/tast/remote/firmware/data/fw-testing-configs"
)
CROS_GO_WORKSPACE=(
"${CROS_WORKON_DESTDIR[@]}"
)
CROS_GO_TEST=(
# Also test support packages that live above remote/bundles/.
"chromiumos/tast/..."
)
CROS_GO_VET=(
"${CROS_GO_TEST[@]}"
)
inherit cros-workon tast-bundle
DESCRIPTION="Bundle of remote integration tests for Chrome OS"
HOMEPAGE="https://chromium.googlesource.com/chromiumos/platform/tast-tests/"
LICENSE="BSD-Google"
KEYWORDS="*"
IUSE=""
# Build-time dependencies should be added to tast-build-deps, not here.
DEPEND="chromeos-base/tast-build-deps:="
RDEPEND=""