blob: 20736b3673f41f57af5b73e0baa671c37c14843b [file] [log] [blame]
# Copyright 2020 The Chromium OS Authors. All rights reserved.
# Use of this source code is governed by a BSD-style license that can be
# found in the LICENSE file.
EAPI=7
CROS_WORKON_COMMIT="d637294e264adfeb29f390dfc393106fd4d41b17"
CROS_WORKON_TREE="5ea09cc328ef299f1d252026d4ea9982e53dd496"
CROS_WORKON_PROJECT="chromiumos/third_party/u-boot"
CROS_WORKON_LOCALNAME="u-boot/files"
CROS_WORKON_SUBTREE="tools/dtoc"
PYTHON_COMPAT=( python3_{6..9} )
inherit cros-workon distutils-r1
DESCRIPTION="Dtoc tool (from U-Boot) for converting devicetree files to C"
HOMEPAGE="https://www.denx.de/wiki/U-Boot"
LICENSE="GPL-2"
SLOT="0/0"
KEYWORDS="*"
IUSE=""
BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
RDEPEND="dev-vcs/patman"
src_unpack() {
cros-workon_src_unpack
S+=/tools/dtoc
}