blob: 235807051113ef6ff0f902678ba792f52ff3d8e1 [file] [log] [blame]
# Copyright (c) 2012 The Chromium OS Authors. All rights reserved.
# Distributed under the terms of the GNU General Public License v2
EAPI=7
CROS_WORKON_COMMIT="081fe39cfb8084ec287ee1eb4e35eda2549a72e2"
CROS_WORKON_TREE="93103cf11ce2cb7fd059b0b9255fa516a1f730bd"
CROS_WORKON_PROJECT="chromiumos/platform/libevdev"
CROS_WORKON_USE_VCSID=1
CROS_WORKON_OUTOFTREE_BUILD=1
CROS_WORKON_LOCALNAME="platform/libevdev"
inherit cros-debug cros-sanitizers cros-workon cros-common.mk
DESCRIPTION="evdev userspace library"
HOMEPAGE="https://chromium.googlesource.com/chromiumos/platform/libevdev"
LICENSE="BSD-Google"
KEYWORDS="*"
IUSE="-asan"
src_configure() {
sanitizers-setup-env
cros-common.mk_src_configure
}
src_install() {
emake DESTDIR="${ED}" LIBDIR="/usr/$(get_libdir)" install
}