blob: 5f756885b8c8704ebaf81f399dcc4e28a2a59f20 [file] [log] [blame]
# Copyright 2014 The Chromium OS Authors. All rights reserved.
# Distributed under the terms of the GNU General Public License v2
EAPI="5"
CROS_WORKON_COMMIT="c142078820d0707858873cedb290a78d36f531af"
CROS_WORKON_TREE=("eec5ce9cfadd268344b02efdbec7465fbc391a9e" "7605f4da9f129a46d0c2b9c4cb06c3ddd1197fe8" "e7dba8c91c1f3257c34d4a7ffff0ea2537aeb6bb")
CROS_WORKON_INCREMENTAL_BUILD=1
CROS_WORKON_LOCALNAME="platform2"
CROS_WORKON_PROJECT="chromiumos/platform2"
CROS_WORKON_OUTOFTREE_BUILD=1
CROS_WORKON_SUBTREE="common-mk chromeos-dbus-bindings .gn"
PLATFORM_SUBDIR="${PN}"
PLATFORM_NATIVE_TEST="yes"
inherit cros-workon platform
DESCRIPTION="Utility for building Chrome D-Bus bindings from an XML description"
HOMEPAGE="https://chromium.googlesource.com/chromiumos/platform2/+/master/chromeos-dbus-bindings"
LICENSE="BSD-Google"
SLOT="0"
KEYWORDS="*"
IUSE=""
RDEPEND="
dev-libs/expat
sys-apps/dbus"
DEPEND="${RDEPEND}"
src_install() {
dobin "${OUT}"/generate-chromeos-dbus-bindings
}
platform_pkg_test() {
platform_test "run" "${OUT}/chromeos_dbus_bindings_unittest"
}