blob: be642e31571af2cb646db0eae1991879d39bf930 [file] [log] [blame]
# Copyright 2018 The Chromium OS Authors. All rights reserved.
# Distributed under the terms of the GNU General Public License v2
EAPI=7
CROS_WORKON_COMMIT="c142078820d0707858873cedb290a78d36f531af"
CROS_WORKON_TREE=("eec5ce9cfadd268344b02efdbec7465fbc391a9e" "a0d2a8563c4f3a1aad7d4257726179ad3294f00a" "e7dba8c91c1f3257c34d4a7ffff0ea2537aeb6bb")
CROS_WORKON_INCREMENTAL_BUILD="1"
CROS_WORKON_LOCALNAME="platform2"
CROS_WORKON_PROJECT="chromiumos/platform2"
CROS_WORKON_OUTOFTREE_BUILD=1
CROS_WORKON_SUBTREE="common-mk arc/appfuse .gn"
PLATFORM_SUBDIR="arc/appfuse"
inherit cros-workon platform user
DESCRIPTION="D-Bus service to provide ARC Appfuse"
HOMEPAGE="https://chromium.googlesource.com/chromiumos/platform2/+/master/arc/appfuse"
LICENSE="BSD-Google"
KEYWORDS="*"
RDEPEND="
sys-apps/dbus:=
sys-fs/fuse:=
"
DEPEND="${RDEPEND}
chromeos-base/system_api:=
"
BDEPEND="
virtual/pkgconfig
"
src_install() {
platform_install
}
pkg_preinst() {
enewuser "arc-appfuse-provider"
enewgroup "arc-appfuse-provider"
}
platform_pkg_test() {
platform test_all
}