blob: 3e861f90bfd587590d0bb93ed0e9af266c3c2c58 [file] [log] [blame]
# Copyright 2018 The Chromium OS Authors. All rights reserved.
# Distributed under the terms of the GNU General Public License v2
EAPI=7
CROS_WORKON_COMMIT=("57bea6b660706f07f8772d292eb49cbe31dec971" "f538556d439264312e74291d7bef735213f9ab53" "360170e747b466e5b884cb5f50a303dfedaba6be")
CROS_WORKON_TREE=("439856a377d1dd33820d7d2c11c7a2fa4bfc0435" "4e4dfbb8e5d2e543de9f9d5ae03ead03a83c6a54" "7c21ad286a49cc09ef2bd9f6c03939f016e9c889")
CROS_WORKON_PROJECT=(
"chromiumos/platform/tast-tests"
"chromiumos/platform/tast"
"chromiumos/platform/fw-testing-configs"
)
CROS_WORKON_LOCALNAME=(
"platform/tast-tests"
"platform/tast"
"platform/tast-tests/src/chromiumos/tast/remote/firmware/data/fw-testing-configs"
)
CROS_WORKON_DESTDIR=(
"${S}"
"${S}/tast-base"
"${S}/src/chromiumos/tast/remote/firmware/data/fw-testing-configs"
)
CROS_GO_WORKSPACE=(
"${CROS_WORKON_DESTDIR[@]}"
)
CROS_GO_TEST=(
# Also test support packages that live above remote/bundles/.
"chromiumos/tast/..."
)
CROS_GO_VET=(
"${CROS_GO_TEST[@]}"
)
inherit cros-workon tast-bundle
DESCRIPTION="Bundle of remote integration tests for Chrome OS"
HOMEPAGE="https://chromium.googlesource.com/chromiumos/platform/tast-tests/"
LICENSE="BSD-Google"
KEYWORDS="*"
IUSE=""
# Build-time dependencies should be added to tast-build-deps, not here.
DEPEND="chromeos-base/tast-build-deps:="
RDEPEND=""