blob: 515a14f5fb32437c14a98e3e58fbd3d1acc0a5ec [file] [log] [blame]
# Copyright 2022 The ChromiumOS Authors
# Use of this source code is governed by a BSD-style license that can be
# found in the LICENSE file.
EAPI="7"
CROS_WORKON_COMMIT="7e2f3e2cc224b0c5dde18c65195ad97de1ac7d4a"
CROS_WORKON_TREE=("e8224fd5df0b5d89e3ac923aef06ecf7ccce51f1" "f9d448b071fa10e2a2149cdc09b1cb04c5a1634a" "f91b6afd5f2ae04ee9a2c19109a3a4a36f7659e6")
CROS_WORKON_LOCALNAME="platform2"
CROS_WORKON_PROJECT="chromiumos/platform2"
CROS_WORKON_OUTOFTREE_BUILD=1
CROS_WORKON_SUBTREE="common-mk mojo_service_manager .gn"
PLATFORM_SUBDIR="mojo_service_manager"
inherit cros-workon platform user
DESCRIPTION="Daemon to manage mojo interfaces"
HOMEPAGE="https://chromium.googlesource.com/chromiumos/platform2/+/HEAD/mojo_service_manager/README.md"
LICENSE="BSD-Google"
KEYWORDS="*"
IUSE=""
DEPEND="
chromeos-base/system_api
chromeos-base/vboot_reference:=
"
BDEPEND="
chromeos-base/minijail
"
pkg_preinst() {
enewuser mojo-service-manager
enewgroup mojo-service-manager
}
platform_pkg_test() {
platform test_all
}