blob: 9678005676d258a4a6ea468e5d76bd373c778dee [file] [log] [blame]
# Copyright 2018 The Chromium OS Authors. All rights reserved.
# Distributed under the terms of the GNU General Public License v2
EAPI=7
CROS_WORKON_COMMIT="0f30e679cfa077ec2b52502e778d50aa45738cc8"
CROS_WORKON_TREE=("81608e81e7a1a6aacd7096a66fd44588c1d5ece9" "f008fb9e266cb811b8604fca21e59d8114dab267" "e7dba8c91c1f3257c34d4a7ffff0ea2537aeb6bb")
CROS_WORKON_PROJECT="chromiumos/platform2"
CROS_WORKON_LOCALNAME="platform2"
CROS_WORKON_OUTOFTREE_BUILD=1
CROS_WORKON_SUBTREE="common-mk storage_info .gn"
PLATFORM_SUBDIR="storage_info"
inherit cros-workon platform
DESCRIPTION="Chrome OS storage info tools"
HOMEPAGE="https://chromium.googlesource.com/chromiumos/platform2/+/HEAD/storage_info/"
SRC_URI=""
LICENSE="BSD-Google"
SLOT="0/0"
KEYWORDS="*"
IUSE="mmc nvme +sata test"
DEPEND=""
RDEPEND="${DEPEND}
chromeos-base/chromeos-common-script
sata? ( sys-apps/hdparm sys-apps/smartmontools )
nvme? ( sys-apps/smartmontools )
mmc? ( sys-apps/mmc-utils )"
platform_pkg_test() {
platform_test "run" "test/storage_info_unit_test"
}
src_install() {
insinto /usr/share/misc
doins share/storage-info-common.sh
}