blob: dcbe98987e02326ad0702c188c673d988075a760 [file] [log] [blame]
# Copyright 2020 The Chromium OS Authors. All rights reserved.
# Distributed under the terms of the GNU General Public License v2
EAPI=7
CROS_WORKON_COMMIT="745cdedb276031fbceedfb76854b10a234cab662"
CROS_WORKON_TREE=("e7dba8c91c1f3257c34d4a7ffff0ea2537aeb6bb" "a9db923ed9d7e66024405ab4fdb8bbe178930040" "318ca9f48604274cd31481e13eb9321be3d94d8f" "f4393b535673365e930c04efeab0ab4a23a5a8a0" "21f96983b4c04d23267767a4f371212fe68039d9" "ef118ceb3e8ebcc8b8a4ae6577a71d7ad210a722")
CROS_WORKON_PROJECT="chromiumos/platform2"
CROS_WORKON_LOCALNAME="../platform2"
CROS_WORKON_SUBTREE=".gn camera/build camera/tools/connector_client camera/common camera/include common-mk"
CROS_WORKON_OUTOFTREE_BUILD="1"
CROS_WORKON_INCREMENTAL_BUILD="1"
PLATFORM_SUBDIR="camera/tools/connector_client"
inherit cros-camera cros-workon platform
DESCRIPTION="A simple package that exercises cros-camera-libcamera_connector"
LICENSE="BSD-Google"
KEYWORDS="*"
RDEPEND="chromeos-base/cros-camera-libs"
DEPEND="${RDEPEND}
x11-libs/libdrm"
BDEPEND="virtual/pkgconfig"
src_install() {
platform_src_install
dobin "${OUT}/cros_camera_connector_client"
}