blob: db7518d157e91829b2da59ca092c5cd862fadd5e [file] [log] [blame]
# Copyright 2021 The Chromium OS Authors. All rights reserved.
# Distributed under the terms of the GNU General Public License v2
EAPI=7
CROS_WORKON_PROJECT="chromiumos/platform/dev-util"
CROS_WORKON_LOCALNAME=("../platform/dev")
CROS_WORKON_SUBTREE="src/chromiumos/test/execution src/chromiumos/test/util"
inherit cros-go cros-workon
DESCRIPTION="Test execution server for running tests and capturing results"
HOMEPAGE="https://chromium.googlesource.com/chromiumos/platform/dev-util/+/HEAD/src/chromiumos/test/execution"
LICENSE="BSD-Google"
KEYWORDS="~*"
IUSE=""
CROS_GO_VERSION="${PF}"
CROS_GO_BINARIES=(
"chromiumos/test/execution/cmd/cros-test"
)
CROS_GO_TEST=(
"chromiumos/test/execution/cmd/cros-test/..."
)
CROS_GO_VET=(
"${CROS_GO_TEST[@]}"
)
DEPEND="
chromeos-base/tast-cmd:=
chromeos-base/tast-proto
dev-util/lro-server
"
RDEPEND="${DEPEND}"
src_prepare() {
# Disable cgo and PIE on building Tast binaries. See:
# https://crbug.com/976196
# https://github.com/golang/go/issues/30986#issuecomment-475626018
export CGO_ENABLED=0
export GOPIE=0
default
}