blob: 14e56772bbf69b3bce7dcd058e37c1f67ace1ce9 [file] [log] [blame]
# Copyright 2020 The Chromium OS Authors. All rights reserved.
# Use of this source code is governed by a BSD-style license that can be
# found in the LICENSE file.
EAPI=7
CROS_WORKON_LOCALNAME="platform2"
CROS_WORKON_PROJECT="chromiumos/platform2"
CROS_WORKON_OUTOFTREE_BUILD=1
CROS_WORKON_INCREMENTAL_BUILD=1
CROS_WORKON_SUBTREE="common-mk bootid-logger croslog .gn"
PLATFORM_SUBDIR="bootid-logger"
inherit cros-workon platform
DESCRIPTION="Program to record the current boot ID to the log"
HOMEPAGE="https://chromium.googlesource.com/chromiumos/platform2/+/HEAD/bootid-logger"
LICENSE="BSD-Google"
SLOT="0/0"
KEYWORDS="~*"
IUSE=""
RDEPEND=">=chromeos-base/croslog-0.0.1-r45"
DEPEND="${RDEPEND}"
src_install() {
platform_install
insinto /etc/init
doins log-bootid-on-boot.conf
}
platform_pkg_test() {
platform test_all
}