blob: c6878f80402f52d1a05952809a0871cf1d58737b [file] [log] [blame]
# Copyright 2018 The ChromiumOS Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="7"
CROS_WORKON_COMMIT="97728d4e124889973e4ca85603996e50d9c98d52"
CROS_WORKON_TREE=("37d329a97f82a57aff6d460abf922676cdabd15f" "1e3a238a4fbe3762df99ba7ad42134b0fb1074aa" "f91b6afd5f2ae04ee9a2c19109a3a4a36f7659e6")
CROS_WORKON_PROJECT="chromiumos/platform2"
CROS_WORKON_LOCALNAME="platform2"
CROS_WORKON_OUTOFTREE_BUILD=1
CROS_WORKON_SUBTREE="common-mk chromeos-common-script .gn"
PLATFORM_SUBDIR="chromeos-common-script"
WANT_LIBCHROME="no"
WANT_LIBBRILLO="no"
inherit cros-workon platform
DESCRIPTION="Chrome OS storage info tools"
HOMEPAGE="https://chromium.googlesource.com/chromiumos/platform2/+/HEAD/chromeos-common-script/"
SRC_URI=""
LICENSE="BSD-Google"
SLOT="0"
KEYWORDS="*"
IUSE="direncryption fsverity prjquota"
src_install() {
platform_src_install
insinto /usr/share/misc
doins share/chromeos-common.sh
doins share/lvm-utils.sh
if use direncryption; then
sed -i '/local direncryption_enabled=/s/false/true/' \
"${D}/usr/share/misc/chromeos-common.sh" ||
die "Can not set directory encryption in common library"
fi
if use fsverity; then
sed -i '/local fsverity_enabled=/s/false/true/' \
"${D}/usr/share/misc/chromeos-common.sh" ||
die "Can not set fs-verity in common library"
fi
if use prjquota; then
sed -i '/local prjquota_enabled=/s/false/true/' \
"${D}/usr/share/misc/chromeos-common.sh" ||
die "Can not set project quota in common library"
fi
}