blob: 49550f74499944771b92bd388d59d0cd922a8a2e [file] [log] [blame]
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI="7"
CROS_WORKON_COMMIT="d6e328d118f95829e569b07692e727f82e34f030"
CROS_WORKON_TREE="a3e5ce4259de770713970232d0b5a43edc478a83"
CROS_WORKON_PROJECT="chromiumos/third_party/mesa"
CROS_WORKON_LOCALNAME="mesa-freedreno"
CROS_WORKON_EGIT_BRANCH="chromeos-freedreno"
inherit base meson multilib-minimal flag-o-matic toolchain-funcs cros-workon arc-build
DESCRIPTION="OpenGL-like graphic library for Linux"
HOMEPAGE="http://mesa3d.sourceforge.net/"
# Most of the code is MIT/X11.
# ralloc is LGPL-3
# GLES[2]/gl[2]{,ext,platform}.h are SGI-B-2.0
LICENSE="MIT LGPL-3 SGI-B-2.0"
SLOT="0"
KEYWORDS="*"
IUSE="
cheets
cheets_user
cheets_user_64
debug
selinux
vulkan
android_vulkan_compute_0
"
REQUIRED_USE="
cheets
android_vulkan_compute_0? ( vulkan )
"
DEPEND="cheets? (
>=x11-libs/arc-libdrm-2.4.82[${MULTILIB_USEDEP}]
)"
RDEPEND="${DEPEND}"
# Fix lint errors
: "${ARC_VM_PREFIX:=}"
: "${ARC_SYSROOT:=}"
pkg_setup() {
# workaround for b/226576333. Also, lld is faster then gold
append-flags -fuse-ld=lld
}
src_prepare() {
# workaround for cros-workon not preserving git metadata
if [[ ${PV} == 9999* && "${CROS_WORKON_INPLACE}" != "1" ]]; then
echo "#define MESA_GIT_SHA1 \"git-deadbeef\"" > src/git_sha1.h
fi
# apply patches
if [[ ${PV} != 9999* && -n ${SRC_PATCHES} ]]; then
EPATCH_FORCE="yes" \
EPATCH_SOURCE="${WORKDIR}/patches" \
EPATCH_SUFFIX="patch" \
epatch
fi
default
}
src_configure() {
cros_optimize_package_for_speed
arc-build-select-clang
multilib-minimal_src_configure
}
multilib_src_configure() {
tc-getPROG PKG_CONFIG pkg-config
if use vulkan; then
VULKAN_DRIVERS=virtio-experimental
fi
# The AOSP build system defines the Make variable
# PLATFORM_SDK_VERSION, and Mesa's Android.mk files use it to
# define the macro ANDROID_API_LEVEL. Arc emulates that here.
if [[ -n "${ARC_PLATFORM_SDK_VERSION}" ]]; then
CPPFLAGS+=" -DANDROID_API_LEVEL=${ARC_PLATFORM_SDK_VERSION}"
fi
arc-build-create-cross-file
emesonargs+=(
--prefix="${ARC_VM_PREFIX}/vendor"
--sysconfdir=/system/vendor/etc
-Ddri-search-path="/system/$(get_libdir)/dri:/system/vendor/$(get_libdir)/dri"
-Dgallium-va=false
-Dgallium-vdpau=false
-Dgallium-xvmc=false
-Dgallium-omx=disabled
-Dglx=disabled
-Ddri3=false
-Dgles-lib-suffix=_mesa
-Degl-lib-suffix=_mesa
-Dfreedreno-virtio=true
-Dplatforms="android"
-Dllvm=disabled
-Degl=enabled
-Dgbm=disabled
-Dgles1=enabled
-Dgles2=enabled
-Dshared-glapi=enabled
$(meson_use selinux)
-Ddri-drivers=
-Dgallium-drivers="virgl,freedreno"
-Dvulkan-drivers="${VULKAN_DRIVERS}"
--buildtype $(usex debug debug release)
--cross-file="${ARC_CROSS_FILE}"
-Dplatform-sdk-version="${ARC_PLATFORM_SDK_VERSION}"
)
meson_src_configure
}
# The meson eclass exports src_compile but not multilib_src_compile. src_compile
# gets overridden by multilib-minimal
multilib_src_compile() {
meson_src_compile
}
multilib_src_install() {
if use vulkan; then
exeinto "${ARC_VM_PREFIX}/vendor/$(get_libdir)/hw"
newexe "${BUILD_DIR}"/src/virtio/vulkan/libvulkan_virtio.so vulkan.cheets.so
fi
exeinto "${ARC_VM_PREFIX}/vendor/$(get_libdir)"
newexe "${BUILD_DIR}/src/mapi/shared-glapi/libglapi.so.0" libglapi.so.0
exeinto "${ARC_VM_PREFIX}/vendor/$(get_libdir)/egl"
newexe "${BUILD_DIR}/src/egl/libEGL_mesa.so" libEGL_mesa.so
newexe "${BUILD_DIR}/src/mapi/es1api/libGLESv1_CM_mesa.so" libGLESv1_CM_mesa.so
newexe "${BUILD_DIR}/src/mapi/es2api/libGLESv2_mesa.so" libGLESv2_mesa.so
exeinto "${ARC_VM_PREFIX}/vendor/$(get_libdir)/dri"
newexe "${BUILD_DIR}/src/gallium/targets/dri/libgallium_dri.so" virtio_gpu_dri.so
}
multilib_src_install_all() {
# For documentation on the feature set represented by each XML file
# installed into /vendor/etc/permissions, see
# <https://developer.android.com/reference/android/content/pm/PackageManager.html>.
# For example XML files for each feature, see
# <https://android.googlesource.com/platform/frameworks/native/+/master/data/etc>.
# Install init files to advertise supported API versions.
insinto "${ARC_VM_PREFIX}/vendor/etc/init"
doins "${FILESDIR}/gles32.rc"
# Install vulkan related files.
if use vulkan; then
einfo "Using android vulkan."
insinto "${ARC_VM_PREFIX}/vendor/etc/init"
doins "${FILESDIR}/vulkan.rc"
insinto "${ARC_VM_PREFIX}/vendor/etc/permissions"
doins "${FILESDIR}/android.hardware.vulkan.version-1_1.xml"
doins "${FILESDIR}/android.hardware.vulkan.level-1.xml"
fi
if use android_vulkan_compute_0; then
einfo "Using android vulkan_compute_0."
insinto "${ARC_VM_PREFIX}/vendor/etc/permissions"
doins "${FILESDIR}/android.hardware.vulkan.compute-0.xml"
fi
# Install permission file to declare opengles aep support.
insinto "${ARC_VM_PREFIX}/vendor/etc/permissions"
doins "${FILESDIR}/android.hardware.opengles.aep.xml"
# Install the dri header for arc-cros-gralloc
insinto "${ARC_VM_PREFIX}/vendor/include/GL"
doins -r "${S}/include/GL/internal"
}