blob: aa53724e0a50d4bb4dba5a9a7c35c02cf54b5fbf [file] [log] [blame]
# Copyright 2022 The Chromium OS Authors. All rights reserved.
# Distributed under the terms of the GNU General Public License v2
EAPI="7"
CROS_RUST_REMOVE_DEV_DEPS=1
inherit cros-rust
DESCRIPTION='FFI bindings to the various libwayland-*.so libraries. You should only need this crate if you are working on custom wayland protocol extensions. Look at the crate wayland-client for usable bindings.'
HOMEPAGE='https://crates.io/crates/wayland-sys'
SRC_URI="https://crates.io/api/v1/crates/${PN}/${PV}/download -> ${P}.crate"
LICENSE="MIT"
SLOT="${PV}/${PR}"
KEYWORDS="*"
DEPEND="
dev-rust/dlib:=
>=dev-rust/lazy_static-1.0.2 <dev-rust/lazy_static-2.0.0_alpha:=
=dev-rust/libc-0.2*:=
>=dev-rust/memoffset-0.6.4 <dev-rust/memoffset-0.7.0_alpha:=
>=dev-rust/pkg-config-0.3.7 <dev-rust/pkg-config-0.4.0_alpha:=
"
RDEPEND="${DEPEND}"
# This file was automatically generated by cargo2ebuild.py