blob: 10268eb3ec679533e24b6982c464f063f1306edc [file] [log] [blame]
# Copyright 2022 The Chromium OS Authors. All rights reserved.
# Distributed under the terms of the GNU General Public License v2
EAPI=7
CROS_WORKON_INCREMENTAL_BUILD=1
CROS_WORKON_LOCALNAME="platform2"
CROS_WORKON_PROJECT="chromiumos/platform2"
CROS_WORKON_OUTOFTREE_BUILD=1
CROS_WORKON_SUBTREE="common-mk hiberman .gn"
PLATFORM_NATIVE_TEST="yes"
PLATFORM_SUBDIR="hiberman/client"
inherit cros-workon platform
DESCRIPTION="Hibernate manager DBus client library for Chromium OS"
HOMEPAGE="https://chromium.googlesource.com/chromiumos/platform2/+/HEAD/hiberman/"
LICENSE="BSD-Google"
KEYWORDS="~*"
IUSE="cros_host"
DEPEND=""
RDEPEND=""
BDEPEND="
chromeos-base/chromeos-dbus-bindings:=
"
src_install() {
# Install DBus client library.
platform_install_dbus_client_lib "hibernate"
}