blob: b77ec6557c6d9a7efc33b2a739c35f770fdd0c49 [file] [log] [blame]
# Copyright 2010 Chromium OS Authors
# Distributed under the terms of the GNU General Public License v2
# $Header: $
EAPI=4
CROS_WORKON_COMMIT="e55ea5ef9a56dbfd851030c0e4c25e96db141ece"
CROS_WORKON_TREE="c65d26079244f4817d23ede7296eb0e913a5dd20"
CROS_WORKON_PROJECT="chromiumos/third_party/coreboot"
CROS_WORKON_LOCALNAME="coreboot"
inherit cros-workon toolchain-funcs
DESCRIPTION="Superiotool allows you to detect which Super I/O you have on your mainboard, and it can provide detailed information about the register contents of the Super I/O."
HOMEPAGE="http://www.coreboot.org/Superiotool"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 x86"
RDEPEND="sys-apps/pciutils"
DEPEND="${RDEPEND}"
src_compile() {
emake -C util/superiotool CC="$(tc-getCC)"
}
src_install() {
emake -C util/superiotool DESTDIR="${D}" install
}