blob: 941c0d3cea299e07b3676789f1d8f35e0c37243f [file] [log] [blame]
# Copyright (c) 2011 The Chromium OS Authors. All rights reserved.
# Distributed under the terms of the GNU General Public License v2
EAPI=7
CROS_WORKON_COMMIT="fd9120658cb5253b7feffa8903742a367ed7571c"
CROS_WORKON_TREE="7fba3fbaf5f4b3d95027ac22c7f18264adf38c4e"
CROS_WORKON_PROJECT="chromiumos/platform/crostestutils"
CROS_WORKON_LOCALNAME="crostestutils"
CROS_WORKON_SUBTREE="recover_duts"
inherit cros-workon
DESCRIPTION="Test tool that recovers bricked Chromium OS test devices"
HOMEPAGE="https://chromium.googlesource.com/chromiumos/platform/crostestutils/+/master/recover_duts/"
LICENSE="BSD-Google"
SLOT="0/0"
KEYWORDS="*"
RDEPEND="
chromeos-base/chromeos-init
"
DEPEND=""
src_unpack() {
cros-workon_src_unpack
S+="/recover_duts"
}
src_install() {
dosbin reload_network_device
exeinto /usr/libexec/recover-duts
newexe recover_duts.sh recover_duts
exeinto /usr/libexec/recover-duts/hooks
doexe hooks/*
}