blob: 64b76394451e977937abdba1590dad5b6a4fd029 [file] [log] [blame]
# Copyright 2017 The Chromium OS Authors. All rights reserved.
# Distributed under the terms of the GNU General Public License v2
EAPI=5
CROS_WORKON_COMMIT="f248db1f0fc22cac2345bc128a6a0a3276c7c430"
CROS_WORKON_TREE=("e7dba8c91c1f3257c34d4a7ffff0ea2537aeb6bb" "4be8d3ae5664634825afc2e6e4b8c24816ee9b9e" "f4e43ea494df44704ba2c63dc081d63a689e6a41" "fcb83ee936c01758d591bb6f7a7734f054dd30ae" "0db6495c85c9186f120853ea040436bf4259ef96")
CROS_WORKON_PROJECT="chromiumos/platform2"
CROS_WORKON_LOCALNAME="../platform2"
CROS_WORKON_SUBTREE=".gn camera/build camera/common camera/include common-mk"
CROS_WORKON_OUTOFTREE_BUILD="1"
CROS_WORKON_INCREMENTAL_BUILD="1"
PLATFORM_SUBDIR="camera/common/libcab_test"
inherit cros-camera cros-workon platform
DESCRIPTION="Test for camera algorithm bridge library"
LICENSE="BSD-Google"
SLOT="0"
KEYWORDS="*"
RDEPEND="
chromeos-base/cros-camera-libs
dev-cpp/gtest:="
DEPEND="${RDEPEND}"
src_install() {
dobin "${OUT}/libcab_test"
dolib.so "${OUT}/lib/libcam_algo_test.so"
}