blob: 80c5ed6ecd0aad8f224310de06b8dc6a3552d1f9 [file] [log] [blame]
# Copyright 2019 The Chromium OS Authors. All rights reserved.
# Distributed under the terms of the GNU General Public License v2
EAPI=7
CROS_WORKON_COMMIT="f248db1f0fc22cac2345bc128a6a0a3276c7c430"
CROS_WORKON_TREE=("0db6495c85c9186f120853ea040436bf4259ef96" "ebd80d3e9a0d5136bc9154864fc7c23cea4a5861" "944879c9353c2df8adb7022407a8d319671325c1" "0c8e3de65339e7e6a1ffe16a54c7ae719bacc57c" "e7dba8c91c1f3257c34d4a7ffff0ea2537aeb6bb")
CROS_WORKON_INCREMENTAL_BUILD=1
CROS_WORKON_LOCALNAME="platform2"
CROS_WORKON_PROJECT="chromiumos/platform2"
CROS_WORKON_OUTOFTREE_BUILD=1
# TODO(crbug.com/809389): Avoid directly including headers from other packages.
CROS_WORKON_SUBTREE="common-mk sealed_storage tpm_manager trunks .gn"
PLATFORM_SUBDIR="sealed_storage"
inherit cros-workon platform
DESCRIPTION="Library for sealing data to device identity and state"
HOMEPAGE="https://chromium.googlesource.com/chromiumos/platform2/+/HEAD/sealed_storage"
LICENSE="BSD-Google"
KEYWORDS="*"
IUSE="test tpm2"
REQUIRED_USE="tpm2"
COMMON_DEPEND="
chromeos-base/tpm_manager:=[test?]
chromeos-base/trunks:=[test?]
"
RDEPEND="${COMMON_DEPEND}"
DEPEND="${COMMON_DEPEND}
chromeos-base/protofiles:=
chromeos-base/system_api:=
"
src_install() {
platform_install
}
platform_pkg_test() {
platform test_all
}