blob: 0b63fb7b0b6e2cb9882ed445e172aebb56fdd8dc [file] [log] [blame]
# Copyright 2019 The Chromium OS Authors. All rights reserved.
# Distributed under the terms of the GNU General Public License v2
EAPI=7
CROS_WORKON_COMMIT="f248db1f0fc22cac2345bc128a6a0a3276c7c430"
CROS_WORKON_TREE=("0db6495c85c9186f120853ea040436bf4259ef96" "a6691fe1e00666995d1480ebcc515c990861e702" "e7dba8c91c1f3257c34d4a7ffff0ea2537aeb6bb")
CROS_WORKON_INCREMENTAL_BUILD=1
CROS_WORKON_LOCALNAME="platform2"
CROS_WORKON_PROJECT="chromiumos/platform2"
CROS_WORKON_OUTOFTREE_BUILD=1
CROS_WORKON_SUBTREE="common-mk libipp .gn"
PLATFORM_SUBDIR="libipp"
inherit cros-workon platform
DESCRIPTION="The library for building and parsing IPP (Internet Printing Protocol) frames."
HOMEPAGE="https://chromium.googlesource.com/chromiumos/platform2/+/HEAD/libipp/"
LICENSE="BSD-Google"
KEYWORDS="*"
src_install() {
platform_install
# Install fuzzer
local fuzzer_component_id="167231"
platform_fuzzer_install "${S}"/OWNERS "${OUT}"/libipp_fuzzer \
--comp "${fuzzer_component_id}"
}
platform_pkg_test() {
platform test_all
}